I’m trying to configure ospf between cisco catalyst 9500 and huawei s5731. I have performed basic ospf configuration, and both switches could recognize each other as ospf neighbor. Then I configured cryptographic authentication on both switches:

catalyst 9500 config:

key chain ospf1

key 1

key-string **************************

cryptographic-algorithm hmac-sha-256

interface Vlan11

ip address 172.23.23.2 255.255.255.0

ip ospf authentication key-chain ospf1

ip ospf network point-to-point

ip ospf 50 area 0
!
router ospf 50

network 172.23.23.0 0.0.0.255 area 0

huawei S5731 config:

interface Vlanif11

ip address 172.23.23.1 255.255.255.0

ospf authentication-mode hmac-sha256 1 plain ****************************

ospf network-type p2p

ospf enable 50 area 0.0.0.0

ospf 50 router-id 2.2.2.2

area 0.0.0.0

network 172.23.23.0 0.0.0.255

After authorization has been configured, switches cannot recognize each other as ospf neighbors.

What is wrong with my configuration?

Leave a Reply

Your email address will not be published. Required fields are marked *